VMware Snapshots Can Prevent Upgrade of Virtual Machines

When upgrading VMware Workstation from a previous version (in this case, version 4) to version 6, snapshots can prevent the virtual machines created under the old version from being upgraded to version 6.  There are two solutions: [more]

  1. Prior to installing version 6, remove all snapshots from the virtual machines.  Also, it is a good idea to make sure all the virtual machines have been shut down gracefully and there are not any .lck files associated with them.
  2. If you have already upgraded to version 6 and still have snapshots, you may get an error message when attempting to upgrade the virtual machine that says something along the lines of, “this virtual machine cannot be upgraded because it has a legacy snapshot.”  When you go to remove the snapshot, the option is grayed-out.  It fix this issue without reverting the old version of Workstation, do the following steps:
    1. For the virtual machine you want to upgrade (vmware1, as an example), rename the file vmware1.vmx.sav to something else.
    2. Open the file vmware1.vmx in WordPad and delete these lines:
      1. undopoints.seqNum = "0"
      2. ide0:0.mode = "undoable"
      3. undopoint.restoreFromCheckpoint = "FALSE"
      4. undopoint.checkpointedOnline = "FALSE"
      5. ide0:0.redo = ".\VM1- XP Pro.vmdk.REDO_a05076”
    3. Save and close vmware1.vmx
    4. Open the virtual machine in Workstation 6 and choose the menu item “VM -> Upgrade or Change Version” to update the version.

Networking VMware