Exchange 2010 Installation Error Organization Preparation Failed

While trying to install Exchange 2010, the process failed with the following error:

Organization Preparation Failed

Error:

The following error was generated when "$error.Clear(); install-ExchangeSchema -LdapFileName ($roleInstallPath + "Setup\Data\"+$RoleSchemaPrefix + "schema0.ldf")

" was run: "There was an error while running 'ldifde.exe' to import the schema file 'C:\Windows\Temp\ExchangeSetup\Setup\Data\PostWindows2003_schema0.ldf'. The error code is: 8224. More details can be found in the error file: 'C:\Users\administrator.{your-domain}\AppData\Local\Temp\2\ldif.err'".

There was an error while running 'ldifde.exe' to import the schema file 'C:\Windows\Temp\ExchangeSetup\Setup\Data\PostWindows2003_schema0.ldf'. The error code is: 8224. More details can be found in the error file: 'C:\Users\administrator.{your-domain}\AppData\Local\Temp\2\ldif.err' [more]

A quick try again and it failed at the same spot. Fortunately, a friendly blogger had run into a similar situation and provided some workarounds - http://www.petenetlive.com/KB/Article/0000442.htm

Basically, we need to run the organization prep tasks manually. I logged onto the Schema Master with my setup DVD attached and ran “Setup.exe /PrepareSchema” and then “Setup.exe /PrepareAD”. Now, since the Schema work has already been taken care of, when I ran the Exchange 2010 setup on the new server, it passed those checks easily and allowed me to continue the install.

Networking Exchange 2010